Home Forums Art WordPress Theme Low image quality

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #22050
    vitorrloureiro
    Participant
    Purchased
    Expired

    Hey,

    I’m trying to upload some photos to a site using ART theme, and they are very high res (like 6000×4000). I need them to be on that resolution when they are displayed in the lightbox. However, when I upload them to wordpress, they are automatically resized to 2560×1707. I tried changing the settings on WordPress’ settings>media, but didn’t work. I also tried to use that plugin method of setting WordPress compression to 100 in order to avoid it. Nothing worked. I suspect it might be something related to the theme…

    Can you help me, please?

    Thanks in advance,

    Vitor

    #22053
    SeaTheme
    Keymaster
    Purchased
    Expired

    Hi,

    Please go to Art Theme>Theme options>General Settings: enable “Disable Image Srcset”.


    If it doesn’t, please leave your website URL, I will check the lived webpage, thanks

    Regards!

    SeaTheme – SeaTheme.netTwitterFacebook

    #22056
    vitorrloureiro
    Participant
    Purchased
    Expired

    Hey, thanks!

    Your suggestion together with a little bit of code to disable WordPress maximum image size did the work.

    I ended up making a plugin with these two lines and nothing more:

    add_filter(‘jpeg_quality’, function($arg){return 100;});
    add_filter( ‘big_image_size_threshold’, ‘__return_false’ );

    Maybe this is a good option to have natively on the theme?

    Anyway, thought it would be nice to share with you guys in case someone else needs help with this matter.

    Thank you very much,

    Vitor

    #22058
    SeaTheme
    Keymaster
    Purchased
    Expired

    Hi,

    Thanks for sharing.
    We will consider adding the option in the future.

    Best

    #23065
    manuuug
    Participant
    Purchased
    Supported

    Hi!

    I am having the same problem that the colleague commented. When uploading a render, I notice that the program compresses it for me despite being previously compressed for web pages (700kb (2000×1800)). I have tried to add the command that comments on it, but it turned out to be impossible.

    Is there an option so that neither the template nor the wordpress itself does not touch the images that are uploaded at all? I lose a lot of image quality.

    Thanks.

    #23074
    SeaTheme
    Keymaster
    Purchased
    Expired

    Hi,

    Did you enable the option?

    Please go to Art Theme>Theme options>General Settings: enable “Disable Image Srcset”.


    If it doesn’t work, please leave your website URL, I will check the lived webpage, thanks

    Regards!

    #23080
    manuuug
    Participant
    Purchased
    Supported

    Yes!.

    But i can’t send u my url. Because it is a website that is on an internal network and cannot be accessed from outside

    #23090
    SeaTheme
    Keymaster
    Purchased
    Expired

    Hi,

    Do you mean that the original images are not shown on the page?
    Let us make sure it from the webpage firstly .
    Please use Chrome to visit your webpage, find the <img tag, and paste the screenshot to me:
    refer to the 2 screenshots
    https://www.dropbox.com/s/im04te7gw2suqdl/qq20201124-095940.jpg?dl=0
    https://www.dropbox.com/s/7osej670tdrnofy/qq20201124-100205.jpg?dl=0

    Could you please send your question(this topic URL) and screenshots to uiueux@gmail.com ?

    Regards

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

Join Newsletter(FREE)

Subscribe to our newsletter to receive news & updates. We promise to not spam you, super promise!